FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

We've set up FrontlineSMS and it works, but we cannot get the Frontline Forms module to cooperate.

 

We are using a Sierra GSM (AT&T) C885 modem to connect to FrontlineSMS 1.6.16.3. And have tested both Nokia S40 Series and S60 Series Phones (3110c, 3150-2 XpressMusic and Nokia E63, and a Nokia C50 (T-Mobile).

 

In each case:

The PC can send a normal SMS message to each phone and it is received by the phone.

 

The SMS Client on the phones can send a request for a new form to the PC running FrontlineSMS 1.6.16.3.

 

The request for a new form message is successfully received by the PC.

 

The PC sends the form to the phone with no error messages.

 

However, in all cases the Frontline client on the phone never acknowledges receipt of the form. The screen "Your SMS was sent. Please wait for a reply" appears, but nothing more happens.

 

This is the conversation:


Status "Received":AAI+gCUAAAECAQElDQIAAA==
Status "Sent": 012500000025000101000103070A0006546573742D310F0800050010476174686572205465737420466F726D000A456E74657220446174650009456E74657220416765000A4669727374204E616D6500094C617374204E616D650A0900050A02040707

Thinking it might be a carrier issue, even though we tried two here in the US, we asked our associates in Uganda to test it as well. They have had the same lack of success.

Have others experienced this problem? How have you resolved it?

 

If it is an issue with the phones, can you advise if the 10 phones listed on the Wiki and Google Docs that have a "Yes" in the Forms SMS Column are the only devices that do work? 

 

Thanks!

Views: 122

Reply to This

Replies to This Discussion

Hi Andrew

 

I'll ask Alex, our hot-shot developer, to respond to you tomorrow. Forms can be a little particular, so I won't hazard a guess quite yet as to what might be going wrong. Back with you shortly!

 

Ken

Hi Andrew,

 

The message from FrontlineSMS to FrontlineForms is in binary format, so there are a few possibilities:

1. the modem is unable to send binary SMS

2. the carrier is rejecting binary SMS

3. the handsets are unable to receive binary SMS

 

We can probably rule out 3 as you say you've used a number of different, and 2 seems very unlikely so I'd suggest trying a different modem.

It's worth checking also, have your associates in Uganda been using the same modem as you?  Have they experienced exactly the same issue at exactly the same point in the process?

 

Alex

Hi Alex, 

 

Thanks for the suggestions. We are thinking

 

1. The Modem is the Sierra Wireless C885 recommended on the FrontlineSMS Site. Also, FrontlineSMS on the PC shows that the form SMS was successfully sent.

 

2. Carrier. Could be, but the Frontline Forms gave the same result with the carrier in Uganda - the FronlineSMS PC software shows that the form SMS was successfully sent.

 

3. Handsets are unable to receive binary SMS seems the most likely, but we have tried so many different ones including several that are known to work with FrontlineSMS.

 

Can you or other forum readers offer any specifics we can try in either US or Uganda - a specific phone paired with a specific carrier which has worked / is working?

 

Thanks! We are really very eager to get this working. We think FrontlineSMS is a great product and want to integrate it and the Forms module into our toolbox.

 

Best regards,

 

Andrew

 

 

Hi Andrew,


We'll take a look from this end and see if we can recreate your problem.  The phones we have listed are by no means the only ones that will work - they are likely ones we have tried ourselves, or people have reported are working.

 

Hopefully someone else can help with your specific problem.

 

Best wishes,

 

Alex

Hey, Andrew :)

I HAVE been able to get Forms working here in the US! I'm using the latest version of FLSMS (1.6.16.3), a Sierra Wireless USBConnect Mercury modem w/an AT&T SIM, and a Nokia N85 (which isn't actually listed as a supported device -- it runs Symbian -- but the client installed successfully) also w/an AT&T SIM.

But if I remember correctly, it didn't automatically work at first. I think I tried to send the form to the phone from FLSMS and it didn't work -- I received the message but it didn't show up as a form in the client. Then I entered the phone number for the FLSMS machine into the client and submitted a request for the form and that worked. When I went back to the main menu I was able to enter data into the new form and also submit it successfully back to FLSMS.

I'm not sure if any of that will help, but I CAN confirm that I've been able to get Forms working correctly.

Hi James, I have a Nokia N85 and I have not been able to make it work. Did you configure anything additional?

It sounds like it was just trial and error for James - at which point is the process failing for you?

Laura

Just an update here, it's working now. The problem was that we were using T-Mobile SIMS in the Phones and AT&T SIM in the Modem.

We are using the C855 Sierra Wireless Modem AT&T branded. When I switched the phones a Nokia XpressMusic and a Nokia C5-00 to AT&T SIMS. The forms started working.

 

This is good news for people needing to test FLSMS Forms in the U.S.A

 

-john

 

Thanks for letting us know, John! Great news.

 

And thanks, James, for helping out here, too.

 

Ken

Thanks, James, for your post! 

Ken, it would be great if FLSMS could post a list not only of phones and modems, but also (as James provided) the complete "recipe" for successful forms deployments: Country - Carrier - Handset - Modem - FLSMS Forms software version. 

We're looking forward to integrating FLSMS with our GATHERdata platform.

 

Best regards,

Andrew

 

Hi Andrew!

 

Very good point, and we'll certainly get onto it. There are a number of ingredients needed to get this right - and we're glad you've managed to get up and running yourself.

 

Please do keep us posted on your progress, and let us know if we can be of any further help.

 

Ken

RSS

Photos

  • Add Photos
  • View All

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service