FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

Feedback on the beta release of FrontlineSMS Version 2 for Linux

Hi all


We are releasing an experimental beta of FrontlineSMS Version 2 for Linux. Linux users make up a very small percentage of our user base, so we are not able to devote significant resources to supporting it. However, if you do have feedback and comments, please post them here.

You can download the installer from our Beta Products page.

Thanks in advance

Laura

Views: 1885

Reply to This

Replies to This Discussion

Hi,

A "member of the dialout group" means that the user can access the modem. This is a linux administrative thing that sometimes needs to be done for some linux distros.

You can find out more by going to this link http://www.howtogeek.com/50787/add-a-user-to-a-group-or-second-grou...

You will need to add the user to the "dialout" group. This group should be a secondary group.

Regards

Problems connecting modem - Ubuntu 13.10 32 bit.

I installed Frontline 2.3.1 linux using your frontlinesms2_unix_2.3.1.sh file on a Ubuntu 32 bit 13.10 machine. The install went fine however I cannot connect to my Huawei 303 GSM modem. The modem connects to the internet automatically when plugged in. I have added the dialout group to this user and also have usb-modeswitch is installed.

Normally I disconnect the modem internet connection prior to starting Frontline however I have tried starting Frontline with the modem on-line. Same results, modem not found.

I think clues about my problem can be found by doing a dmesg | tail command. Here is what I get after connecting the modem:
[14244.108586] systemd-udevd[7709]: Failed to apply ACL on /dev/sr1: No such file or directory
[14244.247685] usb 2-3: USB disconnect, device number 15
[14245.668081] usb 2-3: new high-speed USB device number 16 using ehci-pci
[14245.801176] usb 2-3: New USB device found, idVendor=12d1, idProduct=14db
[14245.801186] usb 2-3: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[14245.801193] usb 2-3: Product: HUAWEI HiLink
[14245.801199] usb 2-3: Manufacturer: HUAWEI
[14245.803558] cdc_ether 2-3:1.0 eth1: register 'cdc_ether' at usb-0000:00:1d.7-3, CDC Ethernet Device, 58:2c:80:13:92:63
[14248.360450] CIFS VFS: Error connecting to socket. Aborting operation.
[14248.360564] CIFS VFS: cifs_mount failed w/return code = -101

Any suggestions would be greatly appreciated,

Ray

Hi Ray,

I just sent your logs over to our Technical team and will let  you know what they come back with!

Cathryn

Hi Ray,

There is a linux software called gnome-ppp that you can use to get the port the modem has bound to on your computer. If gnome-ppp recognizes the port, then try explicitly creating a modem connection to that port.

Please let us know how you get one.

Vaneyck, FrontlineSMS Developer

Thanks but gnome-ppp does not detect the modem. Do you have any other ideas of what I can try?

Ray

Hi Ray,

I've just been reading about the Huawei e303. It is designed to give internet access without installation of drivers, achieving this by mounting as a virtual ethernet device rather than as a standard USB modem. For this reason, most software does not detect any port (my understanding is that it does not mount a port at all).

It sounds like you are aware of this, because you mention that you have usb-modeswitch installed, which is the recommended workaround that I've seen for getting it to mount as a standard modem. Unfortunately we don't have an e303 at hand to test this with, but I imagine that you need to configure usb-modeswitch to mount the device as a standard modem, and you can use gnome-ppp as a test to see if you're successful. Without one to play with, we're not sure exactly how to achieve this with modeswitch.

Sorry I can't be more helpful than that. I do hope you manage to get the device to work through this, but the official line on this is that a modem that does not mount as a conventional USB modem is not supported by FrontlineSMS.

- Sitati, dev team.

Hi Sitati,

Thanks for your response. I am quite sure that usb-modeswitch is doing it job and leaves the modem in a "modem" state. I believe that is want the lines above in dmesg | tail are telling me.

Can you tell me how to get gnome-ppp to detect the modem?

When I run the command I get the following:

$ gnome-ppp
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
WVCONF: /home/ray/.wvdial.conf
GNOME PPP: STDOUT: Editing `/dev/null'.
GNOME PPP: STDOUT:
GNOME PPP: STDOUT: Scanning your serial ports for a modem.
GNOME PPP: STDOUT:
GNOME PPP: STDOUT:
GNOME PPP: STDERR: Modem Port Scan<*1>: S0   S1   S2   S3   S4   S5   S6   S7   
GNOME PPP: STDOUT:
GNOME PPP: STDERR: Modem Port Scan<*1>: S8   S9   S10  S11  S12  S13  S14  S15  
GNOME PPP: STDOUT: Sorry, no modem was detected!  Is it in use by another program?
GNOME PPP: STDERR: Modem Port Scan<*1>: S16  S17  S18  S19  S20  S21  S22  S23  
GNOME PPP: STDOUT: Did you configure it properly with setserial?
GNOME PPP: STDERR: Modem Port Scan<*1>: S24  S25  S26  S27  S28  S29  S30  S31  
GNOME PPP: STDOUT:
GNOME PPP: STDOUT: Please read the FAQ at http://alumnit.ca/wiki/?WvDial

When I run sudo modem-manager, I get:
modem-manager[3233]: <info>  ModemManager (version 0.6.0.0) starting...
modem-manager[3233]: <warn>  Could not acquire the org.freedesktop.ModemManager service as it is already taken. Return: 3

usb-devices Gives:
T:  Bus=01 Lev=01 Prnt=01 Port=00 Cnt=01 Dev#=  5 Spd=480 MxCh= 0
D:  Ver= 2.00 Cls=02(commc) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
P:  Vendor=12d1 ProdID=14db Rev=01.02
S:  Manufacturer=HUAWEI
S:  Product=HUAWEI HiLink
C:  #Ifs= 2 Cfg#= 1 Atr=80 MxPwr=500mA
I:  If#= 0 Alt= 0 #EPs= 1 Cls=02(commc) Sub=06 Prot=00 Driver=cdc_ether
I:  If#= 1 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=06 Prot=00 Driver=cdc_ether

The following is encouraging however:

After inserting the modem and doing a ifconfig, the following is added:
eth3      Link encap:Ethernet  HWaddr 58:2c:80:13:92:63  
          inet6 addr: fe80::5a2c:80ff:fe13:9263/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:32 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:11303 (11.3 KB)  TX bytes:15387 (15.3 KB)

however nothing is added to my network manager

Where are you located? Perhaps I could have a E303 modem sent to you.

Thanks for your help,

Ray

My reading of your dmesg output is that the USB device detected is still acting as a Ethernet over USB ("CDC Ethernet Device").

gnome-ppp, like FrontlineSMS, should automatically detect the port. The output shows that it tried and failed to do so. SMSLib, the library we use in FrontlineSMS for modem detections, will only connect to the serial port if it lists message sending and receiving as capabilities. It's plausible that even with the modem modeswitched to 'modem' mode, it does not list the right capabilities.

Our only other suggestion is to try manually listing ports in /dev/, with and without the modem attached. If there are additional ports available with the modem connected in modem mode, you could manually configure a connection in FrontlineSMS using them. This skips the capability check done for automatically detected ports and tries to connect, and may therefore work. I think it's unlikely that the modem's port would support messaging but not respond with it as a capability though.

Our dev office is in Nairobi, Kenya. If modems with virtual ethernet connections become more common, we'll look to expand our device support to cover them. For now it's unlikely that we'd build in special case support for this model. Thanks anyway for offering to send one.

If the manual connection does not work, would it be difficult for you to get one of our officially supported modems? http://devices.frontlinesms.com/pub . We also support Android via an app called SMSSync, which is generally more stable than a modem connection.

Sitati

Hi SItati,

THanks for your information above. It is helpful but I am not connected yet. I was able to obtain a different modem - this time a Huawei E173 and am getting slightly better results. First off, after plugging this modem in, I get a dialog box indicating "The mobile broadband device 'HUAWEI Technology USB Serial POrt' requires a SIM PIN... If I respond with the correct pin I can go try other things such as dmesg | grep tty which indicates:


[ 922.445902] usb 2-3: GSM modem (1-port) converter now attached to ttyUSB0

[ 922.449166] usb 2-3: GSM modem (1-port) converter now attached to ttyUSB1

[ 922.449601] usb 2-3: GSM modem (1-port) converter now attached to ttyUSB2

Another thing is that gnome-ppp now indicates a connection, ie.


GNOME PPP: STDOUT: Found a modem on /dev/ttyUSB0.

GNOME PPP: STDOUT: Modem configuration written to /dev/null.

GNOME PPP: STDERR: ttyUSB0<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

GNOME PPP: STDERR: ttyUSB2<Info>: Speed 9600; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

I have put the following values into FrontlineSMS modem Port field:

ttyUSB2

and

/dev/ttyUSB0

but each time,  Frontline comes back saying "Port cannot be found".

If you have any other suggestions, I would be happy to try them.

We are able to connect using an Android device using SMSSync but the cloud website seems so slow to us here.

Thanks,

Ray

Hi Ray,

Strange that you're getting 'port not found' when it clearly exists (from gnome-ppp output). The Huawei E173 is one of our most commonly used devices though, so we should be able to get it working. Could you try the following:

1. Drop the SIM card's pin protection: you might have to use a phone to do this.

2. Insert the modem, kill all other software that is trying to access it (e.g. gnome-ppp), then start FrontlineSMS, and give it time to see if autodetection works. This can sometimes take a few minutes. If after 5 or so minutes it has not worked, try clicking 'detect modems' in the status section. This attempts to kick-start the auto-connection process, but will at least give you the list of detected ports.

3. If it does not autoconnect at all, attempt manual connection after identifying the port. Be sure again not to have any other software running that tries to access that port. The "/dev/ttyUSB0" you tried earlier looks correct, if it doesn't work, try "/dev/ttyUSB2", which on ubuntu is also SMS-capable (the modem exposes two ports that can be used).

Regarding SMSSync, it can actually be used with the desktop version of FrontlineSMS as well. The Android phone and your FrontlineSMS installation just have to be on the same wireless network (which can even be the ad-hoc wifi network from the phone).

I hope one of those steps gets it working. Please let us know.

Sitati

Hi Sitati,

You have another success! Thanks so much. I put the E173 in a WIndows 7 machine, and run the Autoexec.ext file that came up. Then I started FrontlineSMS version 2 and if autodetected the modem. I supplied the PIN and we were sending and receiving messages in short order. It was using COM6.

Thanks for pointing out that we can run SMSSync from the desktop version. That sounds attractive too - expecially since it will connect with our Linux machines.

I really don't know why the E173 would not connect on the Linux machine - but you gave me some leads to check out. Perhaps it has to do with the fact that I am running 13.10 upgrade (not a fresh install).

I don't know why the E303 would not connect under Windows (tried 2 machines) and of course it would not connect on our Linux machines.

Anyway we now have several options (Cloud and desktop) that will work and we are happy.

Thank you and your team for getting all this developed!

Ray

Hi,

I've installed FrontlineSMS sucessfully on a remote Linux server to which I'm connected via ssh. 

I enabled X11 forwarding, so I can see the splash screen, which doesn't disappear as long as FrontlineSMS runs.

Without enabling X11 forwarding I would get a java.awt.HeadlessException.

My problem now is that I like to run FrontlineSMS with nohup or with screen, so that I don't have to be connected via ssh all the time. But I can't exit the ssh connection as long as the splash screen is still showing.

Is it possible to start FrontlineSMS without the splash screen or am I missing a way to stop the splash screen?

Regards, Ingo

Reply to Discussion

RSS

© 2017   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service