FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

Getting Ubuntu 10.10 (Maverick Meerkat) to recognize a Samba 56 USB

Hello All,

 

I have been reading the discussion:

"Installing FrontlineSMS on Linux Ubuntu"

Posted by Amanda Atwood on December 2, 2009

http://frontlinesms.ning.com/forum/topics/installing-frontlinesms-on

 

Which was extremely helpful, I've got Frontline to work just fine.  However I cannot get Frontline to connect to my Samba 56. 

 

I used the command "sudo ln -sf /dev/ttyUSB0 /dev/ttyS0"

to create the link and it shows up under ttyS0 now.

 

Then I used the command  "sudo wvdialconf" to get Ubuntu to 'notice' the dongle. 

This is what appears (which looks correct after looking over other peoples posts)

 

Editing `/etc/wvdial.conf'.

Scanning your serial ports for a modem.

ttyS0<*1>: ATQ0 V1 E1 -- OK
ttyS0<*1>: ATQ0 V1 E1 Z -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyS0<*1>: Modem Identifier: ATI -- SIEMENS
ttyS0<*1>: Speed 4800: AT -- OK
ttyS0<*1>: Speed 9600: AT -- OK
ttyS0<*1>: Speed 19200: AT -- OK
ttyS0<*1>: Speed 38400: AT -- OK
ttyS0<*1>: Speed 57600: AT -- OK
ttyS0<*1>: Speed 115200: AT -- OK
ttyS0<*1>: Speed 230400: AT -- OK
ttyS0<*1>: Speed 460800: AT -- Speed 460800: AT -- Speed 460800: AT -- Max speed is 230400; that should be safe.
ttyS0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
Modem Port Scan<*1>: S2   S3  
ttyUSB0<*1>: ATQ0 V1 E1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 Z -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 -- OK
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK
ttyUSB0<*1>: Modem Identifier: ATI -- SIEMENS
ttyUSB0<*1>: Speed 4800: AT -- OK
ttyUSB0<*1>: Speed 9600: AT -- OK
ttyUSB0<*1>: Speed 19200: AT -- OK
ttyUSB0<*1>: Speed 38400: AT -- OK
ttyUSB0<*1>: Speed 57600: AT -- OK
ttyUSB0<*1>: Speed 115200: AT -- OK
ttyUSB0<*1>: Speed 230400: AT -- OK
ttyUSB0<*1>: Speed 460800: AT -- Speed 460800: AT -- Speed 460800: AT -- Max speed is 230400; that should be safe.
ttyUSB0<*1>: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0 -- OK

Found a modem on /dev/ttyS0.
Modem configuration written to /etc/wvdial.conf.
ttyS0<Info>: Speed 230400; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"
ttyUSB0<Info>: Speed 230400; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

Found a modem on /dev/ttyUSB0.
Modem configuration written to /etc/wvdial.conf.
ttyUSB0<Info>: Speed 230400; init "ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0"

 

Then I open the Frontline program and it always says "FrontlineSMS was unable to connect to an SMS device"

 

I attempt to add a phone manually and it will not find the port.

Saying "Port [/dev/ttyS0] could not be found"

or

Saying "Port [ttyS0] could not be found"

 

I would greatly appreciate any help thank you.

please be gentle I'm a nube to ubuntu

 

thanks in advance,

Tim 

Views: 349

Reply to This

Replies to This Discussion

Hi Maxym

Thanks for getting in touch about this. I'm afraid Morgan is no longer working with FrontlineSMS (although he does occasionally drop in on the forum), so I've also passed your request onto our lead developer, Alex, to see if he's able to help out. We will get back to you with further information as soon as possible.

Best

Flo

Hi Maxym,

From your log, it appears that there is no RXTX serial library being detected.  Is the RXTX file available on your filesystem?  FrontlineSMS should indicate on the commandline whether it has been successfully detected.

Alex

Hi Alex,

I have librxtx-java installed from the repositories, and I manually added the Archive Morgan posted into the JAVA_HOME/jre/lib/ directory.


I get the following message from the command line:

java version "1.6.0_24"
OpenJDK Runtime Environment (IcedTea6 1.11.1) (6b24-1.11.1-3)
OpenJDK 64-Bit Server VM (build 20.0-b12, mixed mode)
Launching FrontlineSMS.
Please wait...
Experimental: JNI_OnLoad called.
Stable Library
=========================================
Native lib Version = RXTX-2.1-7
Java lib Version = RXTX-2.1-7

-Max

Hi Max,

That's confusing - the console output suggests that RXTX is loading OK, but in the log you posted previously there is the following exception:

java.lang.UnsatisfiedLinkError: no rxtxSerial in java.library.path

Are you still getting this message in your latest logs?

Alex

RSS

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service