FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

Hey FLSMS community!

I am in Haiti trying to help some folks build an SMS-based anti-trafficking network. We are using a Falcom Samba GSM modem which has never steered me wrong, and two diff SIM cards (Digicel & Voila) and I keep getting an error message that says "SIM card invalid: GSM network registration failed)."

I noticed others had this issue but w diff modems. anyone have any ideas as to how i can fix this? We dont have any usb data cables and they are obviously hard to come by at the moment. Let me know if anyone has encountered a similar prob/know how to fix this, thanks!!




Tags: Compatability, Falcom, GSM, Haiti, Samba, Trafficking

Views: 844

Reply to This

Replies to This Discussion

Aashika,

Thanks so much for such a speedy reply! That's extremely useful. It would be great to be in touch with Fondation Espoir - do you know anyone whom I might contact there?

Katherine
YUP, they are our core partner for the Ayiti SMS SOS project as well! you can check out their "Mwen Konte" project at www.mwenkonte.net.

Their Exec Director is Hans Tippenhauer, and he can be reached at hanstippen@gmail.com!

Best of Luck!
Aash
Hi again Aashika (and all others),

I'm finally in possession of a USB modem, manufactured by ZTE and provided by Digicel, but haven't been able to coax FLSMS into recognizing it.

I did install the Digicel-provided software that came on the device, and it does both send and receive SMS, no problem. I've tried starting FLSMS both with and without the Digicel-provided software running in the background; neither has worked. I'm about to try reinstalling FLSMS.

If you have gotten this modem to work, could you post some technical details about your setup? The hardware we have looks like a flat, white, semi-rectangular egg, with a red stripe around the equator. Windows 7 says it is a "ZTE GSM modem" running on COM 22. I'm trying hard to get this setup working before I have to go back to the USA on Monday morning!

Many thanks in advance,
David
After rebooting and not starting the Digicel client software, FLSMS is able to detect the modem, and I'm able to use it to send SMS. However, I'm not able to use it to receive.

If I start up the Digicel client software, I can use it to view received messages---so SMS do make it to the modem, but FLSMS does not detect or is not able to retrieve them. That seems to be true whether or not the Digicel client software is running in the background.

Would any logs be of help?
Hi David

A couple of quick things you may want to try. First, is the modem configured to receive (right-click on the device in the "Phones" tab and check the settings)? Second, are you sure the Digicell program isn't running at all in the background? In almost all cases like this, something is running and grabbing the incoming SMS's before FrontlineSMS can get to them.

If none of this helps then the logs may give us some clues - I'll leave Alex or Morgan (our developers) to respond to that.

Hope you get this running soon!

Ken
Hi Ken, thanks for the speedy reply.

Yes, it's indeed configured to receive (and send). And yup, I'm pretty sure no Digicel processes remain after closing---there's nothing in the system tray, and nothing I don't recognize in the 'Processes' tab in Task Manager.

I'm sending you the logs via email, couldn't upload directly. If any other info would help (screenshots of property panes, etc.) please do let us know.

We have a couple of contact #s in Haiti to try tomorrow---Fadja Pierre helped our staff person pick out a modem, after we met with David Sharpe and Elizabeth Headon and Fadja last Friday at Digicel HQ in PaP. Maybe we'll need to go back there for some hands-on debugging. Fingers crossed,

David
Hey David!

Dont worry, your problem is totally normal. We had the same thing happened to us at first. It looks like you already covered the first major steps, main one being making sure that you doing have the default Digicel program running. One reason why you may not be receiving messages is because it is storing them on it's memory, which only goes up to 30 messages. Do you think you already have that many coming in? We had to go to Digicel directly for some technical support for this. You may also be able to fix it yourself by going to the Digicel program first, and going to the options section (i dont remember the language exactly) and configure the settings so that SMS's arent stored there). If you need further help configuring this, contact Rodrigue @ Rodrigue.Osirus@digicelgroup.com He is awesome and has seen this problem multiple times (and knows FLSMS well cause of us!)

Best of Luck!!!

Aash
Hi Aash, thanks for the reply! We're trying to get in touch with Rodrigue today. David says he's a busy guy but hopefully he'll have time to chat. Speaking of, if you are on Google chat, I'm david.holstius at gmail dot com.

Did you mean "make sure that you do have" or "make sure that you don't have" the default Digicel program running?

We definitely don't have 30 messages yet, and the Digicel program said there are 0 on the SIM. So I don't think it's full.
whoops i meant don't; im very delirious these days :-) When the digicel's software opens up, close it, and then open FLSMS. FLSMS opens/works best if you have the modem plugged in before hand.

i am almost certain is has something to do with the SIM settings, but id have to see it to talk you through it. my gchat name is aashika.d. Hope to catch you there soon!

A
Hi Ken, is there a URL for older releases of FrontlineSMS?

There's a possibility that the newer ZTE modems that Digicel is now distributing are not compatible with the current release---but they think they may have gotten the modem to work with an older release in the past. I think it might be version 1.14.x. If we could get hold of an older installer, we could test this. I'm willing to try every single version if we have to. :-)
YES! Knock on wood, our Digicel modem now appears to be working with an older release (1.5.8) of FrontlineSMS. We are finally able to receive messages. A big shout out to Aashika of Survivors Connect, Rodrigue Osirus of Digicel, and many others for their help and advice.

For reference, we're using Windows 7, and the back of the modem has these identifiers:

Digicel Mobile Connect
EDGE USB Stick DC87-0
ZTE Corporation
MADE IN CHINA
FCC ID:Q78-DC87-0
IMEI: 3580990201990066

Control Panel lists the driver as 'zteusbgser.sys', version 6.2050.0.4, and the Hardware ID as 'USB\VID_19D2&PID_0022&REV_0000&MI_00'.
Hi David,

Glad to hear you've got things working!

Does your modem work with 1.5.8 out of the box? I'd like to work out why it's not working with 1.6.x as well; would you be able to spare some time to help us diagnose the issue?

Alex

RSS

Photos

  • Add Photos
  • View All

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service