FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

Having trouble using Clickatell and modem simultaneously

Hi all, just getting started in this forum.  I am currently located in Argentina implementing a pilot study.  Will be asking patients to send text and then will be sending messages to them as well.  Have elected (from prior advice) to purchase Clickatell credits to send messages and then local SIM w/ modem to receive. 

Problem:  When both modem and clickatell account are displayed in ‘Working Devices’  I am unable to send messages.  I have selected Clickatell account to send and modem to receive, I have verified that Clickatell account is activated and showing credits, and I have reviewed ‘frontlineSMShelp’ and have trialed using 00<country code> and +<country code>number.  Still unable to send message.  If I disconnect the Clickatell account I can send/receive messages without any problem.  I am wondering if there is another step that I am missing in order to use both systems simultaneously?

Thank you for any assistance

Sarah

Views: 161

Reply to This

Replies to This Discussion

Hi Sarah,

 

Sorry to hear you're having trouble.  Any chance you can send us your logs (inside the application select Help > Submit Error Report) and let us know when you've done that?  I expect there's a small error in your Clickatell configuration.

 

Alex

Alex,

Thank you for your assistance.  I have submitted an error report and we will go from there.

Sarah

Hi Sarah,

 

In your logs, the cause for the failure is reported by Clickatell as "UNKNOWN".  Could you contact Clickatell, or check in their web interface to get more info on the problem?

 

Thanks,

 

Alex

Hi Alex,

Was able to resolve problem by creating new API number and setting up new sender ID number but now have a new issue... 

I am able to send text using Clickatell and receive using modem with local number.  However keyword replies 'fail'.  I see the likely cause but unsure how to resolve. Clickatell account uses international country code (e.g. here 54...number) when I reply with my local phone the number is received as 0...number without country code therefore I am assuming Clickatell device unable to recognize and autoreply.  Is there a way to set or change incoming numbers so that will recognize country code so messages can be 'autoreplied' using Clickatell account? 

-Another issue: only able to see received message by selecting 'all messages' but under individual contact only see sent messages.  To make evaluation easier would like to track received by contact under Message tab.

Again, thanks for any assistance.  Did not see other discussion regarding this issue.

Sarah

Hi Sarah

 

Thanks for getting in touch. Glad to hear Alex's advice helped you with part of your problem, but sorry you are still having challenges here! There is a discussion thread here which contains some advice that may help you with this: http://frontlinesms.ning.com/forum/topics/failed-sending-message-with

 

If you continue to have problems then please let us know, and I will ask Alex if he has further advice. Just to let you know the developer team has left for the weekend now, but we will be sure to be back with you early next week, if needed.

 

Many thanks,
Flo 

Thank you Florence,

I reviewed the discussion thread and although I did have some of the same issues initially I was able to resolve.  My challenge now is a bit different.

I have set up 'keyword' which initiates an autoreply but it 'fails'.  I see the likely cause but unsure if it can be resolved other than disconnecting Clickatell account and only using local SIM card and charge as needed. Clickatell account uses international country code (e.g. here in Argentina 54...number  I do not have + or 00 leading) and I am able to send text but when I reply with my local phone the number is received with one leading 0 (e.g. 0...number) and without country code therefore I am assuming Clickatell account is unable to recognize and autoreply.  Is there a way to set or change incoming numbers so that Clickatell will recognize country code and  'autoreplied' function can be accessed using Clickatell account? Or somehow have all incoming numbers on this Clickatell account lead with 54 automatically?

Otherwise the only option I see is use Modem w/ local SIM card for both incoming and sending or use Clickatell account without autoreply option.  

I have emailed Clickatell and have been told that they do not have 2-way access in Argentina currently.

Thank you

Sarah

Hi Sarah,

 

Thanks for this further information, and sorry to hear you are still having problems with this. I am not 100% sure about the answer to your question so I have asked our developer team if they can help shed any light on this, and they will get back to you as soon as possible.

 

Thanks,

Florence

Hi Sarah,

 

Looks like you've fully identified the problem - as the response comes with a local number Clickatell is unable to cope with it.

 

I suspect we could fix it by using an External Command instead of an Auto Reply - let me know what operating system you're running and I'll see if we can get something sorted out... or if you have a technical team maybe they could have a look.

 

Sorry for the inconvenience,

 

Alex

Hi Sarah:

I looked at Clickatell too. Sadly I could never receive the test message so I didn't use the service. Movistar doesn't use the modems SMS message as much as they try to "sell" the data/internet package so adding additional SMS capacity is the cheapest option.

Hope this helps :)

Domingo

RSS

Photos

  • Add Photos
  • View All

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service