FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

Hello,

I am using the Huawei E220 and it works and connects fine but once i leave the system running for a period of time the modem seems to stop working? Frontline sms is still running ok but it wont receive or reply to messages?

Any ideas?

Mark

Views: 186

Reply to This

Replies to This Discussion

Hi Mark,

 

It's hard to tell what might be causing this problem, but there's a few possibilities

* the modem can't cope being connected for that long

* there is a problem with the FrontlineSMS code

* your operating system is going to sleep every so often, halting the modem connection

 

One thing that would really help us is if you could send us your logs - there may be some information in them which will tell us what the problem is.

 

Thanks,

 

Alex

I noticed this because I was just thinking of posting a followup about my own experience with this problem (or another with the same symptoms). See my post http://frontlinesms.ning.com/forum/topics/2052630:Topic:8568 and the discussion afterward, for the various solutions suggested (none worked for me).

That was two years ago. Now I am using a new version of FrontlineSMS, a new computer, new operating system (Windows 7), a new ISP, and new modem (Huawei E156B) and still having the same problem. So it is actually not a unique problem. If it's a matter of bad luck, I'm amazed that after changing everything, I'm still having the same problem. Perhaps it's an issue with certain families of Huawei?

I use Clickatell for outgoing messages, and both it and the E156B stop working at the same time, every hour or so. It's quite frustrating and means that during use I have to be constantly monitoring the program. I've thought about writing a script to stop and restart Frontline every 1/2 hour, but haven't figured that out yet.

I'm going to try installing under Linux and see if I still have the same problem.

Hi Mike,

 

As you say, if it's bad luck, it's -very- bad luck!  Which version of FrontlineSMS are you running currently?

 

Alex

Hi Alex,

 

I am still experiencing this issue.  I set my computer to not sleep but still the modem stops responding.  how do i create logs to send through for you to check?

 

Thanks

 

Mark

Hi Mark,

 

Sorry to hear you've been having this problem. If you've tried all of Alex's suggestions above, then you can submit logs within FrontlineSMS by clicking 'Help' and then 'Submit error report'.

 

I hope that we can get to the bottom of this issue.

 

Best Wishes,

Florence

Hi I have attached the logs zip file.  I ran this after restarting the program so not sure whether it reflects previous errors if not.  I will run again later once it disconnects again,

 

Thanks and any help would be appreciated.

 

Mark

Attachments:

Hi Mark, 

Were you able to solve the issue? I have similar issues with the E220 (+OSX 10.6). Sends messages through FLSMS fine but cannot receive messages. Wrecking my brain trying to figure it out. Any insights would be great:)

Ta

Hi Deepali,

Thanks for getting in touch. Just to check, have you been able to receive messages at all through FrontlineSMS (even single messages)? If not, it will be helpful for you to check if the device you are using is connected in the phones tab of FrontlineSMS? If it is connected, you should also check that you have your phone set to send and receive messages by right clicking on the phone or modem which is connected. A dialogue box should appear, and you need to make sure that you selected to both ‘Use this phone for sending’ and ‘Use this phone for receiving’. You should also just ensure that you do not have a full inbox or sent box, etc., on your SIM to allow new messages to arrive.

Mark, if you have further suggestions based on your experiences please feel free to add. 

Deepali - do let us know how you get on with this, and if you need further assistance.

Thanks

Flo



Hi Flo,

No haven't been able to receive any messages(not a single one), but have been able to send messages. I can see the modem connected under the phones tab, and it is set to send and receive messages. When I put the sim into a phone it works fine. The inbox/outbox has been emptied out, no pin number required. Just can't figure out what's blocking it. 

When I pull out the modem I do get this message and FLSMS quits. Flsms quit unexpectedly while using the librxtxSerial.jnilib plug-in.

Have been through all the troubleshooting tips, combed the messages boards and really not sure what else to do to make it work. 

Adding a Mac plug and play version of FLSMS to my wishlist now:)

Hi Deepali,

Thanks for getting back to me. It can at times be challenging to get FrontlineSMS working on Mac OS, so may be worth you checking out some tips on how to get this working, e.g. here in previous forum discussion and here in our FAQ.

Not sure if this is the problem you're having, though, so if these tips don't help please let me know and send us your logs, and I will ask our developers to help out. 

Thanks

Flo

Thanks for your quick reply Flo. Thankfully it wasn't a Mac issue! The sim had apparantly been storing messages (just because its in a modem, and the previous users weren't deleting them). When I plugged it into FLSMS sending wasn't a problem, but the full inbox prevented any messages being received. The Safaricom shop cleared it for me and now it's all smooth sailing. Thanks for the support!

Hi Deepali,

I'm really pleased to hear that this issue is all sorted now; thanks for letting me know.

I've read a little about your planned use of FrontlineSMS on your profile, and it sounds like you're working on a very interesting system - please do keep us posted on how it works out, and feel free to ask if you have any further questions.

Cheers!

Flo

RSS

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service