FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

I've recently taken a development job in Uganda that will require a lot of data collection in the field.  Having done mindless data-entry before and not wanting to repeat the experience (and to the excitement of my new bosses), I proposed using SMS technology to do the bulk of our data entry.  I downloaded frontlineSMS and bought an unlocked Huawei E173 modem.

There are several problems when I try to launch FrontlineSMS with the modem plugged in.  When FrontlineSMS automatically tries to detect a modem, it says it can't find any.  Then, when I try to manually use a port, it throws a Port in Use exception.

I've looked through the forums (and even on the development site) and here are the solutions I've tried thus far:

  • Ensuring that the client software the modem came with is turned off.
  • Running FrontlineSMS in 32bit mode.
  • Replacing librxtxSerial.jnilib and the RXTX jar file with version 2.2 from the RXTX Wiki

Here are my system configurations:

  • Mac OSX v. 10.6.8
  • Java v. 1.6.0_29
  • Unlocked Huawei E 173 GSM Modem

I'd greatly appreciate any help or support anyone could provide. I've also attached my error logs.

Tags: Huawei, Mac, OSX

Views: 1812

Attachments:

Reply to This

Replies to This Discussion

Edit:  I have gotten this to work.  After doing some digging for PortInUseException Exceptions for Mac OSX, I came across this Arduino forum

The post itself isn't very good, but it appears that there is a problem with permissions on the "/var/lock" directory. What I did was to change the permissions so that I can read and write to this directory. More specifically, I just used Finder to navigate to "/var/" in the root. Then, if you select the "/var/lock/" folder, right click, and select "Get Info". In the lower right, there will be a small padlock icon that's most likely in the locked position. Click it (and enter your password). Change the permissions (at the bottom), until it says that you can both read and write to the folder.  I know it's probably not best practices to edit permissions from Finder, especially in the "/var/" directory, but after a month of struggling with this problem, I'm glad something works. 

After changing these permissions, I opened FrontlineSMS, and it automatically detected my modem for the first time. I've sent a few test messages, and it seems to be working fine. I hope this helps anyone else having difficulty with connecting a modem to a Mac.

-Stuart

Hi Stuart,


Thanks so much for the update, and for sharing this work around with the community here - its great to hear that you are now up and running! It can be a little more tricky for users to get started using FrontlineSMS on a Mac OS, but there are a few ways to tackle this. If you have any further problems please let us know and the team here will do our best to help.


Thanks

Flo

Hi Stuart / Flo,

I'd just like to thank you for this workaround and confirm it worked perfectly for my setup (Huawei E173 / OSX 10.6.8) as well!

Would it be worth adding this to the manual and/or this (fairly old, but featured) thread? http://frontlinesms.ning.com/forum/topics/still-having-problems-with

Axel

Hi Axel, 

Thanks for letting us know that this worked for you - that's great news. We are currently finalising a selection of Frequently Asked Questions from the forum to help FrontlineSMS users, and this is a helpful tip to include in the FAQ! I'll keep the community posted on where the FAQ can be found upon its release.

Thanks again!

Flo

 

Thanks for this.I thinki should as well try out this with MAc Osx.

Thaks again.

Thanks Stuart, this was the answer I was looking for.

Hello, I have the same problem as Stuart and I am trying to go into the /var/ directory. I am not a computer expert and i cant find this directory... how do I get into the directory in the first place and make the changes as mentioned?

Your help is so much appreciated,

Sandra

Hi Sandra,

the /var directory (as well as a whole bunch of others) is hidden in OSX by default.

You can get to it by opening Finder, selecting "Go to Folder" in the "Go" menu and typing "/var".

If you can't find the "lock" folder in there (it may be a hidden folder as well) you may have to tell Finder to show hidden files and folders - see http://lifehacker.com/188892/show-hidden-files-in-finder

Hope that helps!

Axel

hi Axel thanks for your prompt response. With your guide, I managed to open the /var and show all hidden files, but there is no /lock folder inside the /var. I provide some screenshot if you could help to take a look.

Thanks again!

Attachments:

Hi Sandra

You are probably using a different version to the one discussed above - have you tried all the tips in the Troubleshooting Guide?

If so, we can take a look and see what's going on but the advice above may not work for version 2 of FrontlineSMS, which was released in June 2012.

Let me know how you get on,

Laura

Hello Laura thanks for that. I have created a new thread because no matter what I did the problem persists

here's the link to the new post http://frontlinesms.ning.com/forum/topics/problems-connecting-to-gs...

RSS

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service