FrontlineSMS

FrontlineSMS let users send, receive and manage SMS over a mobile network.

I have a USB modem that I got from MTN in Rwanda that I use to get internet access through their service.  It's a Huwei E156G modem and I'd love to use it to try out my new FLSMS. 
     I put an active GSM chip from a T-Mobile phone in it and then put the modem in the USB port on my Windows 7 PC.  Frontline doesn't see it.  I figured either I don't have a driver installed, or the modem is locked, or both.  I tried to get a driver, but I couldn't find it on the Huwei website and the other websites offering an E156G driver all look shady and try to load other software on my PC.  I looked on the modem via Windows Explorer and ran an install script from MTN, thinking that might install the drivers.  That puttered along for a while, but my modem still doesn't show up in Frontline.  I checked on getting an unlock code and that also looks highly questionable.
     Is there a legit way to get this thing working?  Or is it better to buy a clean unlocked modem?  If so, where?

Thanks!

Views: 112

Reply to This

Replies to This Discussion

Hi Hiero

This should work. It's most likely the software that lets you access the web via the modem is locking the device. You'll likely find a solution to this (and other possible problems) if you work through the steps in the "Troubleshooting" section of the "Help" files. Give that a go and let us know what happens.

Ken
Progress so far: The Device is Recognized
1. I found the E156G listed deep in the huaweidevice.com website under Mobile Broadband;
2. In the FAQ for the device, it said to plug the modem into the PC and access it as a CD storage device using Windows Explorer;
3. According to the FAQ, I found AUTORUN.EXE along with a bunch of other stuff--I ran the autorun.exe. I got the install screen for the MTN software and proceeded with the install. It installed ok and I clicked "Finish";
4. After about 2 minutes, I got a "Device Working Properly" message from the PC--the driver had been installed. Note that the driver was stored on the device itself and I didn't have to download a driver;
5. I restarted FLSMS, and this time under the Phones tab, I saw listings for COM1, COM3, and COM4 in the "Unworking Devices" section. (Before there was only COM1);
6. After 2 minutes, FLSMS discovered "Huawei E156G" on COM3 and COM4, but the status was "GSM Network Registration Failed" on both;
7. I figure that the MTN install must have run something, so now I'm hunting for background processes and services that may be out there blocking... nothing obvious yet.
Hi Hiero

Is there a PIN lock on the SIM or modem? If there is, this may be blocking FrontlineSMS. You can't remove the PIN through FrontlineSMS, but you should be able to via the modem software or by putting the SIM into a regular phone and using the menus.

If this doesn't help I'll pass it over to our great devs to help figure it out!

Thanks.

Ken
I put the SIM card back in a cell phone and checked for a PIN code lock on the SIM. I went into Settings and found the Security->Phone and SIM card settings. The PIN code lock keeps the SIM from being used in another cell phone. On my phone, the PIN Code Request is set to "OFF." There is a default password in the PIN code slot, but I guess that having the Code Request set to OFF means that the SIM card is not locked; it never asks me for a PIN code when the phone starts up.

So next I went to the Start->All Programs->"MTN Internet" program that was installed from the device when I ran autorun.exe. MTN is the telecom provider I bought the device from. When the application starts up, it pops up a window that says "Unlock the data card. Please enter the unlock code:___". So I guess the modem is locked by MTN in some way to prevent me from using a different SIM card in the device. I can't get further access to the program until I enter the unlock code, so there it sits for the moment.

By the way, thanks for your awesome support!
Hi Hiero

Okay, so I'd say you've found the problem. FrontlineSMS is being bounced back by the device PIN. If you can remove this then you should be all set - if not you'll need to track down an unlocked device or go to an MTN shop and ask for help.

Sorry you're having problems with this - but in terms of our support, you're welcome! \o/

Ken
1st Attempt at Unlocking the Modem Failed

1. I use PuTTY.exe (http://www.putty.org) as a terminal to talk to the modem;
2. In PuTTY, I selected "Serial" connection and entered COM3 as the port, which I got from FLSMS, and also from the Control Panel->Device Manager->Modems->E156G->Modem tab;
3. I got a blank terminal screen and entered 'AT' ... the modem replied 'OK'
4. I entered 'ATI' ... the modem gave me its IMEI number;
5. I went to the http://a-zgsm.com/huawei.php website and entered the IMEI number. This is an online calculator that generates unlock codes for Huawei modems;
6. Copied the 5-digit security code displayed on the right into the box on the left;
7. The website generated an Unlock Code (53469831, in my case);
8. Back in the PuTTY terminal I typed AT^CARDLOCK="53469831"
9. This is supposed to unlock the modem, but it replied ERROR instead of OK.
Haven't figured out what's wrong. I spent about 4 of my 10 tries and then backed off.
End of Round 1. One thing I'm wondering is whether it didn't work because the modem can't access the MTN network, even though I have the original SIM card in it (I'm now in the U.S.).
Hi Hiero,

interesting try! Have you tried using the MTN interface which prompts "Please enter the unlock code" ?
I guess from now, you should see with MTN what they can do to help you unlock it...
FrontlineSMS will soon include a tool to enter the PIN for the connected SIM card, but locked devices is something different.

Good luck with that, tell us how you get on :)

Morgan

RSS

Photos

  • Add Photos
  • View All

© 2014   Created by FrontlineSMS Admin.   Powered by

Badges  |  Report an Issue  |  Terms of Service